Ubuntu 下的有个别软件设置 
sudo apt-get install virtualbox#【澳门金沙国际】linux安装显卡驱动,下的一部分软件安装。华主席推荐
二零零五年年度一级软件,最棒编辑选用奖得主…..
sudo apt-get install ntfs-3g ntfs-config
#ntfs写入扶助,装完后运营ntfs-config,把四个钩打上即可。楼下方法作废 
sudo apt-get install googleearth googlizer
gtalk#google相关,skyx友情提醒:不引进马甲 gtalk
sudo apt-get install ghex #GNOME 上的十六进制文件编写器 
sudo apt-get install kvm #Full virtualization on x86 hardware
华主席推荐
sudo apt-get install vmware-player #Free virtual machine player from
VMware 
sudo apt-get install makeself #utility to generate self-extractable
archives 
sudo apt-get install sun-java6-jre#安装JAVA6环境 
sudo apt-get install sun-java6-jdk #安装JAVA6环境# 
sudo update-alternatives –config java#设定JAVA环境 
澳门金沙国际 ,sudo apt-get install rox-filer#七个简便的文本管理软件
sudo apt-get install socks4-server socks4-clients #2个socks
代理服务器/soks4代理客户端
sudo apt-get install mc #好像norton commander 工具,skyx 腰痛推荐
sudo apt-get install liferea #超强的rss reader ,明显比akregator好用,
由zhuqin_83目赤推荐 sudo apt-get install axel-kapt gwget
aria2#三十二线程下载工具,也可在论坛search
超强工具prozilla,由雕啸长空关节炎推荐
sudo apt-get install privoxy tor mixmaster anon-proxy
socat#突破风锁线和雁过无痕
sudo apt-get install kdebluetooth #超简单的ubuntu与Bluetooth手提式有线电话机互传文件工具
#蓝牙( Bluetooth® )请参见:    
sudo apt-get install build-essential #build-essential 
sudo apt-get install proxychains #多少个socks4 socks5代理软件
,能够协理apt-get代理 
sudo apt-get install language-support-zh
language-pack-zh#安装汉语语言支持 
sudo apt-get install stardict stardict-common
stardict-cdict-gbstardict-cedict-gb stardict-hanzim
stardict-langdao-ce-gbstardict-langdao-ec-gb stardict-oxford-gb
stardict-xdict-ce-gbstardict-xdict-ec-gb stardict-jcedict
stardict-jedictstardict-jmdict-en-ja stardict-jmdict-ja-en
wyabdcrealpeopletts#安装StarDict
sudo apt-get install rxvt yakuake tilda kuake konsole
multi-gnome-terminal pyqonsole #多少个顶峰 sudo apt-get install viewglob
#二个shell相关的工具
sudo apt-get install nautilus-open-terminal #在右键菜单中参与打开终端
sudo apt-get instll eva amsn wengophone skype licq
#安装im语音摄像聊天软件 
sudo apt-get install beryl emerald emerald-themes#安装beryl 
sudo apt-get install pcmanx-gtk2 qterm mozilla-plugin-pcmanx #安装bbs
客户端 
sudo apt-get install gkrell* #很好的一个东东,装了就精通了 
sudo apt-get install conky# 有意思的三个系统monitor 
sudo apt-get install nmapfe #nmap前端 
sudo apt-get install meld #3个文本、目录相比较器 
sudo apt-get install imagemagick#
e主席(ee)大力推荐介绍的批量修改图片的软件,今后论坛个旁人在搞个人崇拜 
sudo apt-get install kolourpaint #又三个美术软件 
sudo apt-get install tuxpaint #有意思的图案软件 rgbpaint
#getdeb上有,最弱,但很精细的美术软件
mtpaint(getdeb上有,比gpaint强一点的图画软件)。 
sudo apt-get install kompare # 又三个文件相比较器 
sudo apt-get install gnome-commander #gnome 上类似Total
commander的工具
sudo apt-get install krusader #kde 上类似Total commander的工具
sudo sudo apt-get install bum #系统服务管理软件
sudo apt-get install rbot # ruby写的irc bot 
sudo apt-get install sysv-rc-conf
#一款基于perl的开机进度调整工具,sysv-rc-conf执行命令即可
sudo apt-get install rcconf # Debian Runlevel configuration tool
sudo apt-get install rar unrar p7zip* #安装rar 7zip 
sudo apt-get install rpm alien #安装rpm支持 
sudo apt-get install xpdf xpdf-chinese-simplified #设置pdf查看软件
sudo apt-get install xchm xpdf-chinese* #设置chm查看软件
sudo apt-get install gqview #1个图纸浏览器
sudo apt-get install gnomebaker k3b#设置刻录软件 
sudo apt-get install brasero #gnome上的刻录软件 
sudo apt-get install ksnapshot #3个抓屏程序 
sudo apt-get install kinstaller #application installer
sudo apt-get install vncserver #vncserver,vncview默许已经设置了 
sudo apt-get install tightvncserver tightvnc-java #另一个vnc 
sudo apt-get install apt-build #frontend to apt to build, optimize and
install packages
sudo apt-get install vim-full #vim无法高亮展现,然后编辑
/etc/vim/vimrc,废除syntax on后边的”注释符号 sudo apt-get install
firestarter #图片接口的防火墙设定程序 
sudo apt-get install smbfs #smbfs挂载补助 
sudo apt-get install flashplugin-nonfree #安装浏览器Flash插件 
sudo apt-get install gftp kftpgrabber filezilla
kasablanca#安装ftp客户端
sudo apt-get install sun-java5-jdk #安装Java环境 
sudo apt-get install sun-java5-plugin #安装Java环境
sudo apt-get install build-essential # 安装编译环境 
sudo apt-get install yum rpm #redhat相关
sudo apt-get install mysql-client mysql-server #安装mysql服务 
sudo apt-get install kde-i18n-zhcn
kde-i18n-zhtw#k程序中文援救,很讨厌kde ,但不太讨厌qt程序能够这么装 sudo
apt-get install qt4-qtconfig#qt4 gui配制工具, 如字体等,很讨厌kde
,但不太讨厌qt程序能够这么装 sudo apt-get install kcontrol
#k程序gui配制工具,很看不惯kde ,但不太讨厌qt程序能够这样装 
sudo apt-get apache2 mysql-server php4 php4-gd php4-mysql #安装LAMP 
sudo apt-get install d4x azureus amule ktorrent
mldonkey-servermldonkey-gui rtorrent qtorrent bittornado-gui
bittorrent-guitorrentflux deluge-torrent# 多少个下载/bt/电驴 工具 
sudo apt-get install sysstat #安装sar, iostat and mpstat 
sudo apt-get install nmap #互联网端口扫描工具 
sudo apt-get install nfs-common #nfs
sudo apt-get install samba nfs-kernel-server #samba 
sudo apt-get install xvidcap gnome-splashscreen-manager
#设置显示屏摄像录像 / splash 管理 sudo apt-get install istanbul #Desktop
session recorder
sudo apt-get install sysinfo xsysinfo#系统消息查阅 互联网 [pre]$ 
sudo apt-get install d4x //那是linux上的flashget,在apt中能够找到 $ 
sudo apt-get install amule //那是linux上的emule,在apt中可以找到 $
sudo apt-get install eva
//那是linux下的qq,只可是狡猾的腾讯修改了商业事务,用了eva未来再用就不能够不输入验证码才能进入,但eva并不援救验证码,所以最终的结果就是eva再也没办法用了。
$
sudo apt-get install tor privoxy
//匿名动态代理,与之类似的还有JAP和freedom,据他们说freedom速度更快一些 $
sudo apt-get install liferea //2个GTK的离线LANDSS阅读器 $ 
sudo apt-get install curl //多少个利用U奇骏L语法在命令行下工作的文件传输工具
[/pre] 系统 [pre]$ 
sudo apt-get install rar
//安装rar协助,装了之后,压缩包管理器就足以支撑rar格式了 $ 
sudo apt-get install bum //3个毋庸置疑的装置系统运营程序管理器 $
sudo apt-get install xpdf-chinese-simplified
//xpdf的普通话字体补助,不过通过试用,貌似乱码依然,这几个题材得以参考ubuntu
下Evince看pdf文书档案的乱码化解方案 $
sudo apt-get install gnome-commander
//类似norton-commander的文件管理器,作用基本上能用,比较符合用惯了norton-commander的用户

sudo apt-get install nautilus-open-terminal
//在nautilus的右键菜单里打开终端,要重登录才起效 $
sudo apt-get install nautilus-gksu
//在nautilus中以管理员身份打开,要重登录才起效 $
sudo apt-get install ntp //系统时间与internet时间保持同步 $ 
sudo apt-get install meld
//基于gonme的目录差别相比较工具,能够相比较文件夹和文书的变化 $ 
sudo apt-get install enca //三个相当不利的编码转换工具 $ 
sudo apt-get install keepassx
//二个密码管理软件,具有windows版本和linux版本 $ 
sudo apt-get gparted //图形化分区工具 $ 
sudo apt-get install gcolor2 //叁个科学的依照gtk的图形化吸取颜色的工具。

sudo apt-get install unison-gtk
//一个基于gtk的文书和目录同步工具,具有比较和统一功用。 $
sudo apt-get install conduit
//八个很牛的财富共同工具,可以同步网络相册,文件夹,邮件、照片等等财富,万分牛X

sudo apt-get install manpages-zh //粤语man手册,linux操作系统的不可或缺材质
[/pre] 办公软件 [pre]$
sudo apt-get install scribus //3个类似microsoft publisher的排版软件

sudo apt-get install kchmviewer-nokde
//三个看chm的小软件,扶助中文,只是安装后只可以用命令行运转,执行kchmviewer即可
[/pre] 多媒体 [pre]$ 
sudo apt-get install ksnapshot //抓图工具 $ 
sudo apt-get install ogle ogle-gui //dvd 播放器 $
sudo apt-get install mkisofs //貌似是和刻录光盘有关 $ 
sudo apt-get install wink //一个显示器录制工具,能够用来塑造录制教程 $ 
sudo apt-get install gsopcast //三个网络电视机 $ sudo apt-get install
gonmebaker //五个gonme下的刻录光盘软件 $
sudo apt-get install isomaster
//3个管理和生成ISO镜像的小工局,能够提取、修改、删除添加文件,作用挺全的。
$ sudo apt-get krita
//二个小巧的图像编辑软件,比GIMP小巧,但效益对付一般的相片修改已经足足了。
$ sudo apt-get install xaralx imagemagick
//三个巨好的免费矢量图绘制工具,作用不是相似的强,windows下收费,linux下免费。
$ sudo apt-get install gnome-subtitles
//linux下的divx电影的字幕调学校工人具,可视化的哦 [/pre] 游戏 $ sudo
apt-get install wormux //百战天虫linux版,据我体验,比起百战天虫差不少
[pre]
$ sudo apt-get install assaultCube
//七个类似CS的FPS游戏,不过据本身体验,效果比起CS差远了 $ sudo apt-get
install glest glest-data
//三个类似魔兽争霸的3D即时战略游戏,至极不错,强烈推荐。

       树莓派上在python 3 安装wxpython
4.0的时候相对在此以前的本子稍微复杂一些。因为依靠的装置环境相对相比多。很多时候是因为一个尺度出错就会造成安装退步。且查找原因不易。

1.卸载系统中本来的 OpenSC :
  $ sudo apt-get remove libopensc2
  $ sudo apt-get remove libopenct1

1.AMD

自笔者在树莓派3b上安装的进度如下。具体执行1遍即可安装成功。安装进度前边的一行是要专注有个空格。还有贰个难题正是最终2个下载程序要多试几回。

2.装置 OpenSC 注重的软件包:
  $ sudo apt-get install build-essential
  $ sudo apt-get install libssl-dev
  $ sudo apt-get install libpcsclite-dev
  $ sudo apt-get install pcscd
  $ sudo apt-get install automake
  $ sudo apt-get install autoconf
  $ sudo apt-get install autogen
  $ sudo apt-get install libtool

 

pi@raspberrypi:~ $ sudo pip -V

注:假使 pcscd 安装败北,则应用源码安装:
  1)卸载已设置的 pcsclite :
    $ sudo apt-get remove libpcsclite-dev
  2)从 下载
pcsclite-版本号.tar.bz2 源代码包;
  3)安装 pcsclite :
    $ tar xf pcsclite-版本号.tar.bz2
    $ cd pcsc-lite-版本号
    $ ./configure
    注:现身错误提醒:configure: error: install libhal-dev or use
–disable-libhal
      首先选择设置:$ sudo apt-get install libhal-dev
    $ make
    $ sudo make install

$ sudo apt-get install
 fglrx

pi@raspberrypi:~ $ sudo pip3 -V

3.从 下载最新版本的
opensc-版本号.tar.gz;
4.安装 OpenSC :
  $ ./bootstrap
  $ ./configure –enable-openssl –enable-pcsc
  注:出现错误提示:configure: error: xsl-stylesheets are required for
svn build with man
    添加–disable-man选项:$ ./configure –enable-openssl –enable-pcsc
–disable-man
  $ make
  $ sudo make install


pi@raspberrypi:~ $ sudo pip install -U pip

5.运行 opensc-tool 或 pkcs15-init 工具,
  1)出现如下类似错误:
    error while loading shared libraries:
    libpkcs15init.so.2: cannot open shared object file: No such file or
directory
    重新加载一下动态连接库的目录:$ sudo ldconfig

 

pi@raspberrypi:~ $ sudo pip3 -V

  2)出现如下类似错误:
    No smart card readers found
    尝试运营pcscd服务(带输出音讯):$ /usr/local/sbin/pcscd -a -d -f

2.Nvidia

pi@raspberrypi:~ $ sudo pip -V

  3)现身如下类似错误:
    00001001 hotplug_libhal.c:527:HPRegisterForHotplugEvents()
    No bundle files in pcsc drivers directory: /usr/local/pcsc/drivers
    安装 ccid 驱动:
    1>从 下载
ccid-版本号.tar.bz2 源代码包
    2>$ tar xf ccid-版本号.tar.bz2
    3>$ cd ccid-版本号
    4>$ ./configure
      注:出现谬误提醒:
        configure: error: usb.h not found, install libusb or
        use ./configure LIBUSB_CFLAGS=…
        安装 libusb-dev :$ sudo apt-get install libusb-dev
    5>$ make
    6>$ sudo make install
    尝试运维pcscd服务(带输出音信):$ /usr/local/sbin/pcscd -a -d -f
    成功运维,按Ctrl+C终止进度,此次从后台运转:$ /usr/local/sbin/pcscd
-a -d

$ sudo apt-get install
nvidia-current

pi@raspberrypi:~ $ sudo pip install -U pip3

澳门金沙国际 1

 

pi@raspberrypi:~ $ sudo pip3 install -U pip


pi@raspberrypi:~ $ sudo apt-get install python3-pip

 

pi@raspberrypi:~ $ sudo pip3 install –upgrade pip setuptools

—————–installed after———–

sudo pip3 -V

restart your computer

pi@raspberrypi:~ $ sudo apt-get install dpkg-dev

 

pi@raspberrypi:~ $ sudo apt-get install build-essential

pi@raspberrypi:~ $ sudo apt-get install python3.4-dev

pi@raspberrypi:~ $ sudo apt-get install libjpeg-dev

pi@raspberrypi:~ $ sudo apt-get install libtiff-dev

pi@raspberrypi:~ $ sudo apt-get install libsdl1.2-dev

pi@raspberrypi:~ $ sudo apt-get install
libgstreamer-plugins-base0.10-dev

pi@raspberrypi:~ $ sudo apt-get install libnotify-dev

pi@raspberrypi:~ $ sudo apt-get install freeglut3-dev

pi@raspberrypi:~ $ sudo apt-get install libsm-dev

pi@raspberrypi:~ $ sudo apt-get install libwebkitgtk-dev

pi@raspberrypi:~ $ sudo apt-get install libwebkitgtk-3.0-dev

pi@raspberrypi:~ $ sudo pip3 install –upgrade –pre -f
wxPython

相关文章